среда, 11 марта 2009 г.

Rails vs MySQL

RoR 2.2.2 упорно не хочет дружить с MySQL 5.1
В ответ на rake db:migrate получаю

Mysql::Error: Commands out of sync; you can't run this command now: SHOW TABLES

Незнаю в чем собственно толком дело, времени разбираться нет, лечится downgrade'ом MySQL до 5.0...Если кто в курсе в чем проблема - было бы интересно узнать

3 комментария:

энерджи комментирует...

Ты где 5.1 нашёл-то?!
Оно же нестабильное, что от него ожидать, нормальная версия 5.0.*

Pimpl комментирует...

http://dev.mysql.com/downloads/
MySQL 5.1—Generally Available (GA) release for production use

энерджи комментирует...

Буду краток -- пиздят :)